наверх
Свободные IT публикации
быстро и доступно
логин:
пароль:

Работа со списком значений в 1С 8.x


Как создать список значений?

СозданныйСписок = Новый СписокЗначений;

Как добавить элементы в список значений?

СписокСотрудников.Добавить(ТекущийСотрудник, ТекущийСотрудник.ФИО, , Фото); 

СписокСотрудников.Вставить(Инд, ТекущийСотрудник, ТекущийСотрудник.ФИО, , Фото);

Как найти элемент списка значений?

ЭлементСписка = СписокСотрудников.НайтиПоЗначению(ИскомыйСотрудник); 
Если ЭлементСписка <> Неопределено Тогда 
	Сообщить(СписокСотрудников.Индекс(ЭлементСписка)); 
КонецЕсли;

Как обратиться к элементу списка значений?

ЭлементСписка = СписокСотрудников[Инд]; 

ЭлементСписка = СписокСотрудников.Получить(Инд);

Сотрудник = ЭлементСписка.Значение; 
Представление = ЭлементСписка.Представление; 
Пометка = ЭлементСписка.Пометка; 
Картинка = ЭлементСписка.Картинка;

Как перебрать элементы списка значений?

Для Каждого ЭлементСписка Из СписокСотрудников Цикл 
	Сообщить(ЭлементСписка.Значение); 
КонецЦикла; 

СтаршийИндекс = СписокСотрудников.Количество() - 1; 
Для Сч = 0 по СтаршийИндекс Цикл 
	Сообщить(СписокСотрудников[Сч].Значение); 
КонецЦикла;

Как удалить элемент списка значений?

СписокСотрудников.Удалить(0);
Индекс = СписокОбъектов.Количество() - 1; 
Пока Индекс >= 0 Цикл 
	Если ТипЗнч(СписокОбъектов[Индекс].Значение) = Тип("Число") Тогда 
		СписокОбъектов.Удалить(Индекс); 
	КонецЕсли; 
	Индекс = Индекс - 1; 
КонецЦикла;