наверх
Свободные IT публикации
быстро и доступно
логин:
пароль:

Работа с HTML-документами в 1С 8.x

    Заполнение HTML-анкет (пример формы)

    Процедура URLПриИзменении(Элемент) 
    	ЭлементыФормы.ПолеHTML.Перейти(URL); 
    КонецПроцедуры 
    
    Процедура ПолеHTMLДокументСформирован(Элемент) 
    	// Событие возникает и при открытии формы, когда в реквизите 
    	// URL содержится пустая строка. 
    	Если URL <> "" Тогда 
    		Док = ЭлементыФормы.ПолеHTML.Документ; 
    		// При попытке обратиться к несуществующему свойству 
    		// произойдет ошибка 
    		Док.forms["frm"].fam.Value = "Иванов"; 
    		Док.forms["frm"].nam.Value = "Иван"; 
    		Док.forms["frm"].otch.Value = "Иванович"; 
    	КонецЕсли; 
    КонецПроцедуры